Far funzionare Skype su Fedora a 64 bit

Questo è un problema tipico di nella versione a che monta Pulseaudio, poiché ancora è esclusivamente a 32 bit e non va d’accordo con esso.
Come si risolve un problema su ? Andando in rete a cercare chi lo ha risolto prima di noi. Ho cercato ma alla fine non ho trovato nulla che facesse al caso mio, e così ci ho pensato da solo ed ecco la soluzione.
Premetto che la mia scheda sonora funziona perfettamente sia in uscita che in ingresso, basta beccare le prese giuste.
Preciso anche che il mio Skype è il 2.0.0.72 perché sinceramente quello dopo non mi piace, e tutto sommato la 2.1.0.81 non so quanto possa essere migliore per il mio Fedora.

Ho sempre saputo che in realtà questo è un problema di Pulseaudio, perché Skype che è rimasto per Linux un po’ indietro supporta al massimo Alsa. Per cui l’area di intervento è tutto sommato limitata.
Come si fa in genere a capire che problema ha un programma? Lo si apre da terminale e si esamina l’output a schermo. E difatti esso mi ha presentato una bella
ALSA lib pcm.c:2171:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
al che è stato subito palese quello che dovevo fare: istallare quella libreria!
Dove trovarla è compito di yum
yum provides libasound_module_pcm_pulse.so
che mi restituisce
alsa-plugins-pulseaudio-1.0.21-3.fc10.i386 : Alsa to PulseAudio backend
Repo : updates
Matched from:
Other : libasound_module_pcm_pulse.so

evidentemente un collegamento tra Alsa a 32 bit e Pulseaudio! Quindi non resta da fare un
yum install alsa-plugins-pulseaudio-1.0.21-3.fc10.i386
pur sul mio sistema a 64 bit non ha richiesto altri pacchetti per dipendenze.

Istallato riavviato Skype, vado nelle opzioni > sound devices, metto le tendine di “sound out” e “ringing” (la seconda e la terza) a “pulse”, e vedo con soddisfazione che contrariamente a prima il test sound funziona!
Bene non rimane che sistemare il primo parametro, quello del “sound in” scegliendo tra le varie opzioni. La faccio breve ho trovato che l’unica funzionante è HD ATI SB (hw:SB, 2), le altre o la chiamata di test non parte proprio oppure il microfono è muto.
Faccio notare che “ HD ATI SB” è proprio il dispositivo selezionato sul mio mixer Alsa, che ho aperto per dare volume al microfono.
Ancora un attimo per trovare l’ottimale configurazione del mixer: microfono attivato e al 100%, il boost del microfono messo al 20%, e nelle opzioni la sorgente di input messa su “mic” Questo credo dipenda molto da dove avete attaccato lo spinotto e che scheda audio avete.

Se avete problemi a capire qual’è la giusta voce attivate tutto, ricordatevi di levare il mute a tutti i mic mettere tutto al massimo (ad abbassare si fa in tempo) e poi provare una per una tutte le voci del “sound in”. Trovate quella che vi funziona e settatela come credete.

Fate “applica” chiudete le opzioni e fine lì. Adesso io ho Skype perfettamente funzionate! 🙂

Articoli correlati

2 risposte a Far funzionare Skype su Fedora a 64 bit

  • Isabele scrive:

    Guarda ti ringrazio tantissimo.. GRAZIE MILLE!! =) Hai risolto il problema che avevo da un po’ di tempo XD =)

    • Fabrizio Felici scrive:

      Figurati grazie a te per avermi dato feedback!! 😀 Del resto uno scrive certi articoli perché le cose che impara possano essere utili agli altri no? 🙂
      saluti Fab

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *